aboutsummaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDave Reisner <d@falconindy.com>2011-04-23 11:21:10 -0400
committerTom Gundersen <teg@jklm.no>2011-04-23 21:44:05 +0200
commita2b481098b19e49d8d9143bcaf385fccb9ba08e8 (patch)
tree44c1c5657261842548981531e5cf139ab82d752b /PKGBUILD
parent5fcb5afeb15d0617407abfd5b0827153b632d7c4 (diff)
downloadinitscripts-a2b481098b19e49d8d9143bcaf385fccb9ba08e8.tar.xz
Use Makefile to replace install.sh
If we're going to use a Makefile for minilogd, we might as well use it for everything. This has some moving pieces: * fix minilogd rule: minilogd.o is a target dep not a build rule * rename adjtime.cron => adjtime * fixup PKGBUILD to account for changes Signed-off-by: Tom Gundersen <teg@jklm.no>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79f51f8..c5f2acd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,5 +19,10 @@ sha256sums=()
build() {
cd ..
- DESTDIR=${pkgdir} ./install.sh
+ make
+}
+
+package() {
+ cd ..
+ make DESTDIR="$pkgdir" install
}