aboutsummaryrefslogtreecommitdiff
path: root/arch/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'arch/PKGBUILD')
-rw-r--r--arch/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/arch/PKGBUILD b/arch/PKGBUILD
new file mode 100644
index 0000000..3c336b3
--- /dev/null
+++ b/arch/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 168542 2012-10-13 09:29:55Z thomas $
+# Maintainer: Tom Gundersen <teg@jklm.no>
+# Contributor: Thomas Bächler <thomas@archlinux.org>
+# Contributor: Aaron Griffin <aaron@archlinux.org>
+
+pkgname=initscripts
+pkgver=2012.10.1
+pkgrel=1
+pkgdesc="System initialization/bootup scripts"
+arch=('any')
+url="http://www.archlinux.org"
+license=('GPL2')
+provides=('initscripts-systemd')
+conflicts=('initscripts-systemd')
+replaces=('initscripts-systemd')
+backup=(etc/inittab etc/rc.conf etc/rc.local etc/rc.local.shutdown)
+depends=('glibc' 'bash' 'coreutils' 'systemd-tools' 'iproute2' 'ncurses' 'findutils' 'sysvinit-tools')
+optdepends=('dhcpcd: DHCP network configuration'
+ 'bridge-utils: Legacy network bridging support'
+ 'net-tools: Legacy network support'
+ 'wireless_tools: Legacy wireless networking'
+ 'sysvinit: Legacy init support')
+makedepends=(asciidoc)
+install=initscripts.install
+source=("ftp://ftp.archlinux.org/other/initscripts/${pkgname}-${pkgver}.tar.xz")
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ make DESTDIR=${pkgdir} install
+}
+md5sums=('a4a747e73819b81f2218cf5b9bd53703')